{"answers":{"affected":"1 open source package ship an affected version, including abantecart. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-26521 exists.","fix":"Upgrade abantecart to 1.3.2 or later.","what":"CVE-2022-26521 is a high-severity vulnerability in n/a, published on 7 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-26521 and fix it if it is affected.\n\nWhat it is: CVE-2022-26521 is a high-severity vulnerability in n/a, published on 7 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-26521 exists.\n\nAffected packages and fixed versions:\n- abantecart (Bitnami): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-26521/ (Markdown: https://insights.sbomify.com/CVE-2022-26521/index.md)","id":"CVE-2022-26521","markdown":"https://insights.sbomify.com/CVE-2022-26521/index.md","name":"CVE-2022-26521","record":{"aliases":["BIT-abantecart-2022-26521","GHSA-6x87-qx9j-65qp"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Abantecart e-commerce","requires_auth":"high_privilege","summary":"Authenticated administrators can execute arbitrary code by uploading executable files due to configurable image type restrictions.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"abantecart","vendor":"abantecart"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"Abantecart through 1.3.2 allows remote authenticated administrators to execute arbitrary code by uploading an executable file, because the Catalog\u003eMedia Manager\u003eImages settings can be changed by an administrator (e.g., by configuring .php to be a valid image file type).","ecosystems":["Bitnami"],"exploits":{"exploitdb":1,"first_seen":"2023-03-25","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-03-25","kind":"exploitdb","ref":"51058","stars":null,"title":"Abantecart v1.3.2 - Authenticated Remote Code Execution"}],"tier":"weaponised"},"has_fix":true,"headline":"File upload in n/a","id":"CVE-2022-26521","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"file_upload","year":"2022"},"n_packages":1,"n_references":2,"next":{"headline":"Race condition in n/a","id":"CVE-2022-26522"},"packages":[{"ecosystem":"Bitnami","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"abantecart","purl":"pkg:bitnami/abantecart","source":"BIT-abantecart-2022-26521"}],"prev":{"headline":"pgjdbc Arbitrary File Write Vulnerability","id":"CVE-2022-26520"},"products":["n/a"],"published":"2022-03-07","related":[{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2025-50972","kev_date_added":null,"published":"2025-08-27"},{"cvss_score":8.8,"headline":"SQL injection in n/a","id":"CVE-2016-10755","kev_date_added":null,"published":"2019-05-24"},{"cvss_score":7.5,"headline":"Path traversal in n/a","id":"CVE-2025-50971","kev_date_added":null,"published":"2025-08-26"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2021-42050","kev_date_added":null,"published":"2021-12-14"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2018-20141","kev_date_added":null,"published":"2019-03-17"},{"cvss_score":6,"headline":"SQL injection in n/a","id":"CVE-2024-50801","kev_date_added":null,"published":"2024-10-31"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Authenticated administrators can execute arbitrary code by uploading executable files due to configurable image type restrictions.","url":"https://insights.sbomify.com/CVE-2022-26521/"}