# CVE-2022-26521: File upload in n/a

> Authenticated administrators can execute arbitrary code by uploading executable files due to configurable image type restrictions.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-abantecart-2022-26521, GHSA-6x87-qx9j-65qp

## What is CVE-2022-26521?

CVE-2022-26521 is a high-severity vulnerability in n/a, published on 7 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Abantecart through 1.3.2 allows remote authenticated administrators to execute arbitrary code by uploading an executable file, because the Catalog>Media Manager>Images settings can be changed by an administrator (e.g., by configuring .php to be a valid image file type).

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2022-26521?

1 open source package ship an affected version, including abantecart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `abantecart` | Bitnami | All versions | 1.3.2 |

Products: Abantecart Abantecart.

## How do I fix CVE-2022-26521?

Upgrade abantecart to 1.3.2 or later.

## Is CVE-2022-26521 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-26521 exists.

Public exploit code:

- Abantecart v1.3.2 - Authenticated Remote Code Execution (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2025-50972](https://insights.sbomify.com/CVE-2025-50972/): SQL injection in n/a (critical 9.8)
- [CVE-2016-10755](https://insights.sbomify.com/CVE-2016-10755/): SQL injection in n/a (high 8.8)
- [CVE-2025-50971](https://insights.sbomify.com/CVE-2025-50971/): Path traversal in n/a (high 7.5)
- [CVE-2021-42050](https://insights.sbomify.com/CVE-2021-42050/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2018-20141](https://insights.sbomify.com/CVE-2018-20141/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26521 and fix it if it is affected.

What it is: CVE-2022-26521 is a high-severity vulnerability in n/a, published on 7 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-26521 exists.

Affected packages and fixed versions:
- abantecart (Bitnami): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26521/ (Markdown: https://insights.sbomify.com/CVE-2022-26521/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26521
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26521
- OSV: https://osv.dev/vulnerability/CVE-2022-26521

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26521/
Summaries are generated and may contain mistakes; the official description above is the record.
