# CVE-2022-26526: Privilege escalation in n/a

> Local attackers can escalate privileges by placing malicious files in a world-writable directory added to the system PATH during specific non-default installations.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-miniconda-2022-26526, GHSA-4qx4-v2q7-m2gp

## What is CVE-2022-26526?

CVE-2022-26526 is a high-severity vulnerability in n/a, published on 17 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Anaconda Anaconda3 (Anaconda Distribution) through 2021.11.0.0 and Miniconda3 through 4.11.0.0 can create a world-writable directory under %PROGRAMDATA% and place that directory into the system PATH environment variable. Thus, for example, local users can gain privileges by placing a Trojan horse file into that directory. (This problem can only happen in a non-default installation. The person who installs the product must specify that it is being installed for all users. Also, the person who installs the product must specify that the system PATH should be changed.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2022-26526?

1 open source package ship an affected version, including miniconda. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `miniconda` | Bitnami | All versions | 4.11.0 |

Products: Anaconda Anaconda3, Conda Miniconda3.

## How do I fix CVE-2022-26526?

Upgrade miniconda to 4.11.0 or later.

## Is CVE-2022-26526 being exploited?

There is no known exploitation of CVE-2022-26526 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-42969](https://insights.sbomify.com/CVE-2021-42969/): Command injection in n/a (high 8.8)
- [CVE-2024-46060](https://insights.sbomify.com/CVE-2024-46060/): Privilege escalation in n/a (high 7.8)
- [CVE-2023-35845](https://insights.sbomify.com/CVE-2023-35845/): Security feature bypass in n/a (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26526 and fix it if it is affected.

What it is: CVE-2022-26526 is a high-severity vulnerability in n/a, published on 17 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-26526 in the wild and no public exploit code.

Affected packages and fixed versions:
- miniconda (Bitnami): affected all versions; fixed in 4.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26526/ (Markdown: https://insights.sbomify.com/CVE-2022-26526/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26526
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26526
- OSV: https://osv.dev/vulnerability/CVE-2022-26526

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26526/
Summaries are generated and may contain mistakes; the official description above is the record.
