# CVE-2022-2654: Classima < 2.1.11 - Reflected Cross-Site Scripting

> Attackers can execute arbitrary scripts in victim browsers via unescaped parameters in the Classima WordPress theme and related plugins.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Sep 2022
- **Updated:** 5 Jun 2025
- **Also known as:** GHSA-mcf6-w793-99gq

## What is CVE-2022-2654?

CVE-2022-2654 is a medium-severity cross-site scripting vulnerability in Unknown Classified Listing Pro - Classified ads & Business Directory Plugin, published on 16 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Classima WordPress theme before 2.1.11 and some of its required plugins (Classified Listing before 2.2.14, Classified Listing Pro before 2.0.20, Classified Listing Store & Membership before 1.4.20 and Classima Core before 1.10) do not escape a parameter before outputting it back in attributes, leading to Reflected Cross-Site Scripting

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-2654?

It affects 4 products.


Products: Radiustheme Classified Listing, Radiustheme Classified Listing Store \& Membership, Radiustheme Classima, Radiustheme Classima Core.

## How do I fix CVE-2022-2654?

No fix has been published for CVE-2022-2654 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-2654 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2654 exists.

## Other vulnerabilities in Unknown Classified Listing Pro - Classified ads & Business Directory Plugin

- [CVE-2024-1315](https://insights.sbomify.com/CVE-2024-1315/): Classified Listing <= 3.0.4 - Cross-Site Request Forgery to Account Takeover via rtcl_update_user_account (high 8.8)
- [CVE-2024-1352](https://insights.sbomify.com/CVE-2024-1352/): Classified Listing – Classified ads & Business Directory Plugin <= 3.0.4 - Missing Authorization (medium 6.5)
- [CVE-2024-7888](https://insights.sbomify.com/CVE-2024-7888/): Classified Listing – Classified ads & Business Directory Plugin <= 3.1.7 - Missing Authorization (medium 6.3)
- [CVE-2022-2655](https://insights.sbomify.com/CVE-2022-2655/): Classified Listing Pro < 2.0.20 - Reflected Cross-Site Scripting (medium 6.1)
- [CVE-2023-37387](https://insights.sbomify.com/CVE-2023-37387/): WordPress Classified Listing Plugin <= 2.4.5 is vulnerable to Cross Site Request Forgery (CSRF) (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2654 and fix it if it is affected.

What it is: CVE-2022-2654 is a medium-severity cross-site scripting vulnerability in Unknown Classified Listing Pro - Classified ads & Business Directory Plugin, published on 16 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2654 exists.

Affected product: Unknown Classified Listing Pro - Classified ads & Business Directory Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2654/ (Markdown: https://insights.sbomify.com/CVE-2022-2654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2654
- OSV: https://osv.dev/vulnerability/CVE-2022-2654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2654/
Summaries are generated and may contain mistakes; the official description above is the record.
