{"answers":{"affected":"1 open source package ship an affected version, including sass. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-26592 in the wild and no public exploit code.","fix":"Upgrade sass to 3.6.6 or later.","what":"CVE-2022-26592 is a high-severity memory corruption vulnerability in n/a, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-26592 and fix it if it is affected.\n\nWhat it is: CVE-2022-26592 is a high-severity memory corruption vulnerability in n/a, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-26592 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sass (Bitnami): affected from 3.6.5; fixed in 3.6.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-26592/ (Markdown: https://insights.sbomify.com/CVE-2022-26592/index.md)","id":"CVE-2022-26592","markdown":"https://insights.sbomify.com/CVE-2022-26592/index.md","name":"CVE-2022-26592","record":{"aliases":["AZL-32226","AZL-43879","AZL-44100","BIT-sass-2022-26592","DEBIAN-CVE-2022-26592","GHSA-4v29-vc65-87m4","UBUNTU-CVE-2022-26592"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Sass compiler library","requires_auth":"none","summary":"A stack overflow in libsass allows attackers to cause denial of service or potentially execute code via crafted input.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libsass","vendor":"sass-lang"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Stack Overflow vulnerability in libsass 3.6.5 via the CompoundSelector::has_real_parent_ref function.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2022-26592","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"memory_corruption","year":"2022"},"n_packages":1,"n_references":1,"next":{"headline":"Liferay Portal and Liferay DXP allows arbitrary injection via the name of an asset category","id":"CVE-2022-26593"},"packages":[{"ecosystem":"Bitnami","fixed":["3.6.6"],"introduced":["3.6.5"],"last_affected":[],"package":"sass","purl":"pkg:bitnami/sass","source":"BIT-sass-2022-26592"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2022-26591"},"products":["n/a"],"published":"2023-08-22","related":[{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2018-11499","kev_date_added":null,"published":"2018-05-26"},{"cvss_score":8.8,"headline":"Use after free in n/a","id":"CVE-2018-19827","kev_date_added":null,"published":"2018-12-03"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2018-11694","kev_date_added":null,"published":"2018-06-04"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2018-11695","kev_date_added":null,"published":"2018-06-04"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2018-11696","kev_date_added":null,"published":"2018-06-04"},{"cvss_score":8.1,"headline":"Information disclosure in n/a","id":"CVE-2018-11693","kev_date_added":null,"published":"2018-06-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["n/a"]},"summary":"A stack overflow in libsass allows attackers to cause denial of service or potentially execute code via crafted input.","url":"https://insights.sbomify.com/CVE-2022-26592/"}