# CVE-2022-26593: Liferay Portal and Liferay DXP allows arbitrary injection via the name of an asset category

> Remote attackers can inject arbitrary web script or HTML via asset category names in Liferay Portal, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Apr 2022
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-liferay-2022-26593, GHSA-q2rp-xfj8-r95h

## What is CVE-2022-26593?

CVE-2022-26593 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 19 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the Asset module's asset categories selector in Liferay Portal 7.3.3 through 7.4.0, and Liferay DXP 7.3 before service pack 3 allows remote attackers to inject arbitrary web script or HTML via the name of a asset category.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-26593?

5 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom, liferay and com.liferay:com.liferay.asset.taglib. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.3.0 | 7.3.10.fp3 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.3.0 | 7.3.10.fp3 |
| `liferay` | Bitnami | All versions to 7.3.0 | 7.3.0 |
| `com.liferay:com.liferay.asset.taglib` | Maven | All versions | 6.1.0 |
| `com.liferay:com.liferay.asset.taglib` | Maven | All versions | 6.1.0 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2022-26593?

Upgrade com.liferay.portal:release.dxp.bom to 7.3.10.fp3 or later.

## Is CVE-2022-26593 being exploited?

There is no known exploitation of CVE-2022-26593 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26593 and fix it if it is affected.

What it is: CVE-2022-26593 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 19 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-26593 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.3.0; fixed in 7.3.10.fp3
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.3.0; fixed in 7.3.10.fp3
- liferay (Bitnami): affected all versions up to 7.3.0; fixed in 7.3.0
- com.liferay:com.liferay.asset.taglib (Maven): affected all versions; fixed in 6.1.0
- com.liferay:com.liferay.asset.taglib (Maven): affected all versions; fixed in 6.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26593/ (Markdown: https://insights.sbomify.com/CVE-2022-26593/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26593
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26593
- OSV: https://osv.dev/vulnerability/CVE-2022-26593

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26593/
Summaries are generated and may contain mistakes; the official description above is the record.
