# CVE-2022-26596: Liferay Portal and Liferay DXP allows arbitrary injection via web content template names

> Remote attackers can inject arbitrary web script or HTML via web content template names in the Journal module, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Apr 2022
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-liferay-2022-26596, GHSA-w7f2-6896-6mm2

## What is CVE-2022-26596?

CVE-2022-26596 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 25 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in Journal module's web content display configuration page in Liferay Portal 7.1.0 through 7.3.3, and Liferay DXP 7.0 before fix pack 94, 7.1 before fix pack 19, and 7.2 before fix pack 8, allows remote attackers to inject arbitrary web script or HTML via web content template names.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-26596?

9 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom, liferay and com.liferay:com.liferay.journal.content.web. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.0.0 | 7.0.10.fp94 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.0.0 | 7.0.10.fp94 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.1.0 | 7.1.10.fp19 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.1.0 | 7.1.10.fp19 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.2.0 | 7.2.10.fp8 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.2.0 | 7.2.10.fp8 |
| `liferay` | Bitnami | From 7.0.0 to 7.0.0 | None |
| `com.liferay:com.liferay.journal.content.web` | Maven | All versions | 5.0.15 |
| `com.liferay:com.liferay.journal.content.web` | Maven | All versions | 5.0.15 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2022-26596?

Upgrade com.liferay.portal:release.dxp.bom to a fixed version for your release line: 7.0.10.fp94, 7.1.10.fp19 or 7.2.10.fp8.

## Is CVE-2022-26596 being exploited?

There is no known exploitation of CVE-2022-26596 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26596 and fix it if it is affected.

What it is: CVE-2022-26596 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 25 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-26596 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.0.0; fixed in 7.0.10.fp94
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.0.0; fixed in 7.0.10.fp94
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.1.0; fixed in 7.1.10.fp19
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.1.0; fixed in 7.1.10.fp19
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.2.0; fixed in 7.2.10.fp8
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.2.0; fixed in 7.2.10.fp8
- liferay (Bitnami): affected from 7.0.0 up to 7.0.0; no fix listed
- com.liferay:com.liferay.journal.content.web (Maven): affected all versions; fixed in 5.0.15
- com.liferay:com.liferay.journal.content.web (Maven): affected all versions; fixed in 5.0.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26596/ (Markdown: https://insights.sbomify.com/CVE-2022-26596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26596
- OSV: https://osv.dev/vulnerability/CVE-2022-26596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26596/
Summaries are generated and may contain mistakes; the official description above is the record.
