# CVE-2022-26650: Apache ShenYu (incubating) Regular expression denial of service

> Attackers can cause resource exhaustion and denial of service in Apache ShenYu by submitting malicious regular expressions to the predicate judge.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-cw56-j3fm-7w57

## What is CVE-2022-26650?

CVE-2022-26650 is a high-severity denial of service vulnerability in Apache ShenYu (incubating), published on 17 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache ShenYui, ShenYu-Bootstrap, RegexPredicateJudge.java uses Pattern.matches(conditionData.getParamValue(), realData) to make judgments, where both parameters are controllable by the user. This can cause an attacker pass in malicious regular expressions and characters causing a resource exhaustion. This issue affects Apache ShenYu (incubating) 2.4.0, 2.4.1 and 2.4.2 and is fixed in 2.4.3.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-26650?

4 open source packages ship an affected version, including org.apache.shenyu:shenyu and org.apache.shenyu:shenyu-bootstrap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.shenyu:shenyu` | Maven | From 2.4.0 | 2.4.3 |
| `org.apache.shenyu:shenyu` | Maven | From 2.4.0 | 2.4.3 |
| `org.apache.shenyu:shenyu-bootstrap` | Maven | From 2.4.0 | 2.4.3 |
| `org.apache.shenyu:shenyu-bootstrap` | Maven | From 2.4.0 | 2.4.3 |

Products: Apache Shenyu.

## How do I fix CVE-2022-26650?

Upgrade org.apache.shenyu:shenyu to 2.4.3 or later.

## Is CVE-2022-26650 being exploited?

There is no known exploitation of CVE-2022-26650 in the wild and no public exploit code.

## Other vulnerabilities in Apache ShenYu (incubating)

- [CVE-2021-45029](https://insights.sbomify.com/CVE-2021-45029/): Apache ShenYu 2.4.1 Groovy Code Injection & SpEL Injection (critical 9.8)
- [CVE-2021-37580](https://insights.sbomify.com/CVE-2021-37580/): Apache ShenYu Admin bypass JWT authentication (critical 9.8)
- [CVE-2022-23944](https://insights.sbomify.com/CVE-2022-23944/): Apache ShenYu 2.4.1 Improper access control (critical 9.1)
- [CVE-2022-42735](https://insights.sbomify.com/CVE-2022-42735/): Apache ShenYu Admin ultra vires (high 8.8)
- [CVE-2022-37435](https://insights.sbomify.com/CVE-2022-37435/): Apache ShenYu Admin Improper Privilege Management (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26650 and fix it if it is affected.

What it is: CVE-2022-26650 is a high-severity denial of service vulnerability in Apache ShenYu (incubating), published on 17 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-26650 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.shenyu:shenyu (Maven): affected from 2.4.0; fixed in 2.4.3
- org.apache.shenyu:shenyu (Maven): affected from 2.4.0; fixed in 2.4.3
- org.apache.shenyu:shenyu-bootstrap (Maven): affected from 2.4.0; fixed in 2.4.3
- org.apache.shenyu:shenyu-bootstrap (Maven): affected from 2.4.0; fixed in 2.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26650/ (Markdown: https://insights.sbomify.com/CVE-2022-26650/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26650
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26650
- OSV: https://osv.dev/vulnerability/CVE-2022-26650

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26650/
Summaries are generated and may contain mistakes; the official description above is the record.
