# CVE-2022-26662: XML Entity Expansion in trytond and proteus

> An unauthenticated attacker can cause a denial of service in Tryton Application Platform by sending crafted XML-RPC messages exploiting XML Entity Expansion.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-26662, GHSA-pm3h-mm62-pwm8, PYSEC-2022-43171, PYSEC-2026-3392, PYSEC-2026-741, UBUNTU-CVE-2022-26662

## What is CVE-2022-26662?

CVE-2022-26662 is a high-severity vulnerability in Debian Debian Linux, published on 7 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An XML Entity Expansion (XEE) issue was discovered in Tryton Application Platform (Server) 5.x through 5.0.45, 6.x through 6.0.15, and 6.1.x and 6.2.x through 6.2.5, and Tryton Application Platform (Command Line Client (proteus)) 5.x through 5.0.11, 6.x through 6.0.4, and 6.1.x and 6.2.x through 6.2.1. An unauthenticated user can send a crafted XML-RPC message to consume all the resources of the server.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2022-26662?

15 open source packages ship an affected version, including proteus, tryton and trytond. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `proteus` | PyPI | From 5.0.0 | 5.0.12, 6.0.5, 6.2.2 |
| `proteus` | PyPI | From 5.0.0 | 5.0.12 |
| `proteus` | PyPI | From 5.0.0 | 5.0.12 |
| `proteus` | PyPI | From 6.0.0 | 6.0.5 |
| `proteus` | PyPI | From 6.0.0 | 6.0.5 |
| `proteus` | PyPI | From 6.1.0 | 6.2.2 |
| `proteus` | PyPI | From 6.1.0 | 6.2.2 |
| `tryton` | PyPI | From 5.0.0 | 5.0.12, 6.0.5, 6.2.2, 6.2.6, 6.0.16, 5.0.46 |
| `trytond` | PyPI | From 5.0.0 | 5.0.46, 6.0.16, 6.2.6 |
| `trytond` | PyPI | From 5.0.0 | 5.0.46 |
| `trytond` | PyPI | From 5.0.0 | 5.0.46 |
| `trytond` | PyPI | From 6.0.0 | 6.0.16 |
| `trytond` | PyPI | From 6.0.0 | 6.0.16 |
| `trytond` | PyPI | From 6.1.0 | 6.2.6 |
| `trytond` | PyPI | From 6.1.0 | 6.2.6 |

Products: Debian Debian Linux, Tryton Proteus, Tryton Trytond.

## How do I fix CVE-2022-26662?

Upgrade proteus to a fixed version for your release line: 5.0.12, 6.0.5 or 6.2.2.

## Is CVE-2022-26662 being exploited?

There is no known exploitation of CVE-2022-26662 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26662 and fix it if it is affected.

What it is: CVE-2022-26662 is a high-severity vulnerability in Debian Debian Linux, published on 7 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-26662 in the wild and no public exploit code.

Affected packages and fixed versions:
- proteus (PyPI): affected from 5.0.0; fixed in 5.0.12, 6.0.5, 6.2.2
- proteus (PyPI): affected from 5.0.0; fixed in 5.0.12
- proteus (PyPI): affected from 5.0.0; fixed in 5.0.12
- proteus (PyPI): affected from 6.0.0; fixed in 6.0.5
- proteus (PyPI): affected from 6.0.0; fixed in 6.0.5
- proteus (PyPI): affected from 6.1.0; fixed in 6.2.2
- proteus (PyPI): affected from 6.1.0; fixed in 6.2.2
- tryton (PyPI): affected from 5.0.0; fixed in 5.0.12, 6.0.5, 6.2.2, 6.2.6, 6.0.16, 5.0.46
- trytond (PyPI): affected from 5.0.0; fixed in 5.0.46, 6.0.16, 6.2.6
- trytond (PyPI): affected from 5.0.0; fixed in 5.0.46
- trytond (PyPI): affected from 5.0.0; fixed in 5.0.46
- trytond (PyPI): affected from 6.0.0; fixed in 6.0.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26662/ (Markdown: https://insights.sbomify.com/CVE-2022-26662/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26662
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26662
- OSV: https://osv.dev/vulnerability/CVE-2022-26662

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26662/
Summaries are generated and may contain mistakes; the official description above is the record.
