# CVE-2022-26850: Insufficiently protected credentials

> An attacker with local access could read sensitive credentials from a temporary file during configuration updates in Apache NiFi.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-nifi-2022-26850, GHSA-rvp4-r3g6-8hxq

## What is CVE-2022-26850?

CVE-2022-26850 is a medium-severity vulnerability in Apache Nifi, published on 6 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

When creating or updating credentials for single-user access, Apache NiFi wrote a copy of the Login Identity Providers configuration to the operating system temporary directory. On most platforms, the operating system temporary directory has global read permissions. NiFi immediately moved the temporary file to the final configuration directory, which significantly limited the window of opportunity for access. NiFi 1.16.0 includes updates to replace the Login Identity Providers configuration without writing a file to the operating system temporary directory.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2022-26850?

3 open source packages ship an affected version, including org.apache.nifi:nifi-single-user-utils and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-single-user-utils` | Maven | All versions | 1.16 |
| `org.apache.nifi:nifi-single-user-utils` | Maven | All versions | 1.16 |
| `nifi` | Bitnami | From 1.14.0 | 1.16.0 |

Products: Apache Nifi.

## How do I fix CVE-2022-26850?

Upgrade org.apache.nifi:nifi-single-user-utils to 1.16 or later.

## Is CVE-2022-26850 being exploited?

There is no known exploitation of CVE-2022-26850 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26850 and fix it if it is affected.

What it is: CVE-2022-26850 is a medium-severity vulnerability in Apache Nifi, published on 6 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-26850 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-single-user-utils (Maven): affected all versions; fixed in 1.16
- org.apache.nifi:nifi-single-user-utils (Maven): affected all versions; fixed in 1.16
- nifi (Bitnami): affected from 1.14.0; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26850/ (Markdown: https://insights.sbomify.com/CVE-2022-26850/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26850
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26850
- OSV: https://osv.dev/vulnerability/CVE-2022-26850

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26850/
Summaries are generated and may contain mistakes; the official description above is the record.
