CVE-2022-26960 Path Traversal in Studio-42 elFinder through 2.1.60

Critical 9.1 Published Updated

Unauthenticated attackers can read, write, and browse files outside the document root in elFinder due to improper path handling.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-26960?

CVE-2022-26960 is a critical path traversal vulnerability in n/a, published on 21 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

connector.minimal.php in std42 elFinder through 2.1.60 is affected by path traversal. This allows unauthenticated remote attackers to read, write, and browse files outside the configured document root. This is due to improper handling of absolute file paths.

Weakness: CWE-22

Which versions are affected by CVE-2022-26960?

2 open source packages ship an affected version, including studio-42/elfinder. It affects 1 product.

PackageAffectedFixed in
studio-42/elfinder PackagistAll versions2.1.61
studio-42/elfinder PackagistAll versions2.1.61

Products include Std42 Elfinder.

How do I fix CVE-2022-26960?

Upgrade studio-42/elfinder to 2.1.61 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2022-26960 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-26960 exists.

Public exploit code: 1 Nuclei template.

Sources

Also known as GHSA-7q88-jxvp-9gp2.

Is CVE-2022-26960 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free