# CVE-2022-26969: Insecure default value for CORS configuration

> Directus allows cross-origin requests by default, potentially enabling unauthorized data access or actions from malicious sites.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2022
- **Updated:** 14 Apr 2025
- **Also known as:** GHSA-g27j-74fp-xfpr

## What is CVE-2022-26969?

CVE-2022-26969 is a critical vulnerability in Monospace Directus, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Directus before 9.7.0, the default settings of CORS_ORIGIN and CORS_ENABLED are true.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains)

## Which versions are affected by CVE-2022-26969?

2 open source packages ship an affected version, including directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `directus` | npm | All versions | 9.7.0 |
| `directus` | npm | All versions | 9.7.0 |

Products: Monospace Directus.

## How do I fix CVE-2022-26969?

Upgrade directus to 9.7.0 or later.

## Is CVE-2022-26969 being exploited?

There is no known exploitation of CVE-2022-26969 in the wild and no public exploit code.

## Other vulnerabilities in Monospace Directus

- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)
- [CVE-2026-39942](https://insights.sbomify.com/CVE-2026-39942/): Directus has a Path Traversal and Broken Access Control in File Management API (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26969 and fix it if it is affected.

What it is: CVE-2022-26969 is a critical vulnerability in Monospace Directus, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-26969 in the wild and no public exploit code.

Affected packages and fixed versions:
- directus (npm): affected all versions; fixed in 9.7.0
- directus (npm): affected all versions; fixed in 9.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26969/ (Markdown: https://insights.sbomify.com/CVE-2022-26969/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26969
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26969
- OSV: https://osv.dev/vulnerability/CVE-2022-26969

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26969/
Summaries are generated and may contain mistakes; the official description above is the record.
