CVE-2022-27103 element-plus vulnerable to cross-site scripting (XSS) via el-table-column

Medium 6.1 Published Updated

Cross-site scripting vulnerability in element-plus allows attackers to inject malicious scripts via el-table-column, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-27103?

CVE-2022-27103 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

element-plus 2.0.5 is vulnerable to Cross Site Scripting (XSS) via el-table-column.

Weakness: CWE-79

Which versions are affected by CVE-2022-27103?

2 open source packages ship an affected version, including element-plus. It affects 1 product.

PackageAffectedFixed in
element-plus npmAll versions2.0.6
element-plus npmAll versions2.0.6

Products include Element-Plus Element-Plus.

How do I fix CVE-2022-27103?

Upgrade element-plus to 2.0.6 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-27103 being exploited?

There is no known exploitation of CVE-2022-27103 in the wild and no public exploit code.

Sources

Also known as GHSA-rjvg-8v36-xv9r.

Is CVE-2022-27103 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free