# CVE-2022-27115: RCE in Studio-42 elFinder on Windows before 2.1.61

> Attackers can achieve remote code execution by bypassing file name restrictions during file uploads in the elFinder file manager.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-6p96-vfrc-fv32

## What is CVE-2022-27115?

CVE-2022-27115 is a critical vulnerability in n/a, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Studio-42 elFinder 2.1.60, there is a vulnerability that causes remote code execution through file name bypass for file upload.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2022-27115?

2 open source packages ship an affected version, including studio-42/elfinder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `studio-42/elfinder` | Packagist | All versions | 2.1.61 |
| `studio-42/elfinder` | Packagist | All versions | 2.1.61 |

Products: Std42 Elfinder.

## How do I fix CVE-2022-27115?

Upgrade studio-42/elfinder to 2.1.61 or later.

## Is CVE-2022-27115 being exploited?

There is no known exploitation of CVE-2022-27115 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-52044](https://insights.sbomify.com/CVE-2023-52044/): File upload in n/a (critical 9.8)
- [CVE-2024-38909](https://insights.sbomify.com/CVE-2024-38909/): Studio 42 elFinder vulnerable to Incorrect Access Control (critical 9.8)
- [CVE-2021-43421](https://insights.sbomify.com/CVE-2021-43421/): elFinder Unrestricted File Upload vulnerability (critical 9.8)
- [CVE-2021-32682](https://insights.sbomify.com/CVE-2021-32682/): Multiple vulnerabilities leading to RCE (critical 9.8)
- [CVE-2019-9194](https://insights.sbomify.com/CVE-2019-9194/): elFinder command injection vulnerability in the PHP connector (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-27115 and fix it if it is affected.

What it is: CVE-2022-27115 is a critical vulnerability in n/a, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-27115 in the wild and no public exploit code.

Affected packages and fixed versions:
- studio-42/elfinder (Packagist): affected all versions; fixed in 2.1.61
- studio-42/elfinder (Packagist): affected all versions; fixed in 2.1.61

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-27115/ (Markdown: https://insights.sbomify.com/CVE-2022-27115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-27115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-27115
- OSV: https://osv.dev/vulnerability/CVE-2022-27115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-27115/
Summaries are generated and may contain mistakes; the official description above is the record.
