{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:dashboard-view. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-27197 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:dashboard-view to 2.18.1 or later.","what":"CVE-2022-27197 is a medium-severity cross-site scripting vulnerability in Jenkins Dashboard View Plugin, published on 15 Mar 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-27197 and fix it if it is affected.\n\nWhat it is: CVE-2022-27197 is a medium-severity cross-site scripting vulnerability in Jenkins Dashboard View Plugin, published on 15 Mar 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-27197 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:dashboard-view (Maven): affected all versions; fixed in 2.18.1\n- org.jenkins-ci.plugins:dashboard-view (Maven): affected all versions; fixed in 2.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-27197/ (Markdown: https://insights.sbomify.com/CVE-2022-27197/index.md)","id":"CVE-2022-27197","markdown":"https://insights.sbomify.com/CVE-2022-27197/index.md","name":"CVE-2022-27197","record":{"aliases":["GHSA-6fg4-36v7-xv32"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Dashboard View Plugin","requires_auth":"low_privilege","summary":"Attackers with view configuration privileges can inject malicious scripts via unvalidated Iframe URLs, leading to stored cross-site scripting attacks.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"dashboard_view","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Dashboard View Plugin 2.18 and earlier does not perform URL validation for the Iframe Portlet's Iframe source URL, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to configure views.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored Cross-site Scripting vulnerability in Jenkins Dashboard View Plugin","id":"CVE-2022-27197","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"CSRF vulnerability in Jenkins CloudBees AWS Credentials Plugin","id":"CVE-2022-27198"},"packages":[{"ecosystem":"Maven","fixed":["2.18.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:dashboard-view","purl":null,"source":"GHSA-6fg4-36v7-xv32"},{"ecosystem":"Maven","fixed":["2.18.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:dashboard-view","purl":"pkg:maven/org.jenkins-ci.plugins/dashboard-view","source":"GHSA-6fg4-36v7-xv32"}],"prev":{"headline":"Stored Cross-site Scripting vulnerability in Jenkins Favorite Plugin","id":"CVE-2022-27196"},"products":["Jenkins Dashboard View Plugin"],"published":"2022-03-15","related":[{"cvss_score":5.4,"headline":"Cross-site Scripting in Jenkins Dashboard View Plugin","id":"CVE-2021-21649","kev_date_added":null,"published":"2021-05-11"},{"cvss_score":5.4,"headline":"Jenkins Dashboard View Plugin vulnerable to Cross-site Scripting","id":"CVE-2019-10396","kev_date_added":null,"published":"2019-09-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers with view configuration privileges can inject malicious scripts via unvalidated Iframe URLs, leading to stored cross-site scripting attacks.","url":"https://insights.sbomify.com/CVE-2022-27197/"}