CVE-2022-27376 Use after free in n/a

High 7.5 Published Updated

A use-after-free vulnerability in MariaDB Server allows attackers to execute arbitrary code or cause denial of service via crafted SQL statements.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-27376?

CVE-2022-27376 is a high-severity use after free vulnerability in Debian Debian Linux, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

MariaDB Server v10.6.5 and below was discovered to contain an use-after-free in the component Item_args::walk_arg, which is exploited via specially crafted SQL statements.

Weakness: CWE-416

Which versions are affected by CVE-2022-27376?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.

PackageAffectedFixed in
mariadb BitnamiFrom 10.3.010.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4
mariadb-min BitnamiFrom 10.3.010.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4
mysql-client BitnamiFrom 10.3.010.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4

Products include Debian Debian Linux, Mariadb Mariadb.

How do I fix CVE-2022-27376?

Upgrade mariadb to a fixed version for your release line: 10.3.35, 10.4.25, 10.5.16 or 10.6.8.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2022-27376 being exploited?

There is no known exploitation of CVE-2022-27376 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2022-27376, AZL-9689, BIT-mariadb-2022-27376, BIT-mariadb-min-2022-27376, BIT-mysql-client-2022-27376, DEBIAN-CVE-2022-27376 and 2 more.

Is CVE-2022-27376 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free