CVE-2022-27377 Use after free in n/a
A use-after-free vulnerability in MariaDB Server allows attackers to execute arbitrary code or cause denial of service via crafted SQL statements.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-27377?
CVE-2022-27377 is a high-severity use after free vulnerability in Debian Debian Linux, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MariaDB Server v10.6.3 and below was discovered to contain an use-after-free in the component Item_func_in::cleanup(), which is exploited via specially crafted SQL statements.
Weakness: CWE-416
Which versions are affected by CVE-2022-27377?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.2.0 | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mariadb-min Bitnami | From 10.2.0 | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mysql-client Bitnami | From 10.2.0 | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
Products include Debian Debian Linux, Mariadb Mariadb.
How do I fix CVE-2022-27377?
Upgrade mariadb to a fixed version for your release line: 10.2.44, 10.3.35, 10.4.25 or 10.5.16.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2022-27377 being exploited?
There is no known exploitation of CVE-2022-27377 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2022-27377, AZL-9690, BIT-mariadb-2022-27377, BIT-mariadb-min-2022-27377, BIT-mysql-client-2022-27377, DEBIAN-CVE-2022-27377 and 2 more.