CVE-2022-27378 Denial of service in n/a
Attackers can cause a Denial of Service in MariaDB Server by submitting specially crafted SQL statements.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-27378?
CVE-2022-27378 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue in the component Create_tmp_table::finalize of MariaDB Server v10.7 and below was discovered to allow attackers to cause a Denial of Service (DoS) via specially crafted SQL statements.
Weakness: CWE-89
Which versions are affected by CVE-2022-27378?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.2.0 | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4, 10.8.3, 10.9.1 |
mariadb-min Bitnami | From 10.2.0 to 10.9.0 | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4, 10.8.3 |
mysql-client Bitnami | From 10.2.0 | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4, 10.8.3, 10.9.1 |
Products include Debian Debian Linux, Mariadb Mariadb.
How do I fix CVE-2022-27378?
Upgrade mariadb to a fixed version for your release line: 10.2.44, 10.3.35, 10.4.25 or 10.5.16.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-27378 being exploited?
There is no known exploitation of CVE-2022-27378 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2022-27378, AZL-9357, BIT-mariadb-2022-27378, BIT-mariadb-min-2022-27378, BIT-mysql-client-2022-27378, DEBIAN-CVE-2022-27378 and 2 more.