CVE-2022-27379 Denial of service in n/a

High 7.5 Published Updated

Attackers can cause a Denial of Service in MariaDB Server by submitting specially crafted SQL statements.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-27379?

CVE-2022-27379 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue in the component Arg_comparator::compare_real_fixed of MariaDB Server v10.6.2 and below was discovered to allow attackers to cause a Denial of Service (DoS) via specially crafted SQL statements.

Weakness: CWE-89

Which versions are affected by CVE-2022-27379?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.

PackageAffectedFixed in
mariadb BitnamiFrom 10.3.010.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4
mariadb-min BitnamiFrom 10.3.010.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4
mysql-client BitnamiFrom 10.3.010.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4

Products include Debian Debian Linux, Mariadb Mariadb.

How do I fix CVE-2022-27379?

Upgrade mariadb to a fixed version for your release line: 10.3.35, 10.4.25, 10.5.16 or 10.6.8.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-27379 being exploited?

There is no known exploitation of CVE-2022-27379 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2022-27379, AZL-9691, BIT-mariadb-2022-27379, BIT-mariadb-min-2022-27379, BIT-mysql-client-2022-27379, DEBIAN-CVE-2022-27379 and 2 more.

Is CVE-2022-27379 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free