CVE-2022-27382 Null dereference in n/a
A segmentation fault in MariaDB Server allows attackers to cause a denial of service via specific query operations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-27382?
CVE-2022-27382 is a high-severity vulnerability in Mariadb Mariadb, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MariaDB Server v10.7 and below was discovered to contain a segmentation fault via the component Item_field::used_tables/update_depend_map_for_order.
Weakness: CWE-617
Which versions are affected by CVE-2022-27382?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.4.0 | 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mariadb-min Bitnami | From 10.4.0 | 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mysql-client Bitnami | From 10.4.0 | 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
Products include Mariadb Mariadb.
How do I fix CVE-2022-27382?
Upgrade mariadb to a fixed version for your release line: 10.4.25, 10.5.16, 10.6.8 or 10.7.4.
Is CVE-2022-27382 being exploited?
There is no known exploitation of CVE-2022-27382 in the wild and no public exploit code.
Other vulnerabilities in Mariadb Mariadb
- CVE-2026-49261 MariaDB server has unsafe parameter handling in `wsrep_notify_cmd`
- CVE-2026-85746 MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections
- CVE-2026-85748 MariaDB: Use-after-free with a large number of SYS_REFCURSOR's
- CVE-2026-92262 MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass.
- CVE-2023-26785 Code injection in n/a
Sources
Also known as ALPINE-CVE-2022-27382, BIT-mariadb-2022-27382, BIT-mariadb-min-2022-27382, BIT-mysql-client-2022-27382, DEBIAN-CVE-2022-27382, GHSA-6hwc-564p-37h2 and 1 more.