CVE-2022-27385 Denial of service in n/a

High 7.5 Published Updated

Attackers can cause a Denial of Service in MariaDB Server by submitting specially crafted SQL statements.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-27385?

CVE-2022-27385 is a high-severity denial of service vulnerability in Mariadb Mariadb, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue in the component Used_tables_and_const_cache::used_tables_and_const_cache_join of MariaDB Server v10.7 and below was discovered to allow attackers to cause a Denial of Service (DoS) via specially crafted SQL statements.

Weakness: CWE-89

Which versions are affected by CVE-2022-27385?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.

PackageAffectedFixed in
mariadb BitnamiAll versions10.3.32, 10.4.22, 10.5.13, 10.6.5
mariadb-min BitnamiAll versions10.3.32, 10.4.22, 10.5.13, 10.6.5
mysql-client BitnamiAll versions10.3.32, 10.4.22, 10.5.13, 10.6.5

Products include Mariadb Mariadb.

How do I fix CVE-2022-27385?

Upgrade mariadb to a fixed version for your release line: 10.3.32, 10.4.22, 10.5.13 or 10.6.5.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-27385 being exploited?

There is no known exploitation of CVE-2022-27385 in the wild and no public exploit code.

All Mariadb Mariadb vulnerabilities

Sources

Also known as ALPINE-CVE-2022-27385, BIT-mariadb-2022-27385, BIT-mariadb-min-2022-27385, BIT-mysql-client-2022-27385, DEBIAN-CVE-2022-27385, GHSA-m469-6q82-xqvx and 1 more.

Is CVE-2022-27385 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free