CVE-2022-27386 SQL injection in n/a
A segmentation fault in MariaDB Server allows attackers to cause a denial of service via crafted SQL queries.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-27386?
CVE-2022-27386 is a high-severity SQL injection vulnerability in Debian Debian Linux, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MariaDB Server v10.7 and below was discovered to contain a segmentation fault via the component sql/sql_class.cc.
Weakness: CWE-89
Which versions are affected by CVE-2022-27386?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.2.0 | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mariadb-min Bitnami | From 10.2.0 | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mysql-client Bitnami | From 10.2.0 | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
Products include Debian Debian Linux, Mariadb Mariadb.
How do I fix CVE-2022-27386?
Upgrade mariadb to a fixed version for your release line: 10.2.44, 10.3.35, 10.4.25 or 10.5.16.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2022-27386 being exploited?
There is no known exploitation of CVE-2022-27386 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2022-27386, AZL-9360, BIT-mariadb-2022-27386, BIT-mariadb-min-2022-27386, BIT-mysql-client-2022-27386, DEBIAN-CVE-2022-27386 and 2 more.