CVE-2022-27387 Memory corruption in n/a
A global buffer overflow in MariaDB Server allows attackers to execute arbitrary code or cause denial of service via crafted SQL statements.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-27387?
CVE-2022-27387 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MariaDB Server v10.7 and below was discovered to contain a global buffer overflow in the component decimal_bin_size, which is exploited via specially crafted SQL statements.
Weakness: CWE-120
Which versions are affected by CVE-2022-27387?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.2.0 | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mariadb-min Bitnami | From 10.2.0 | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mysql-client Bitnami | From 10.2.0 | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
Products include Debian Debian Linux, Mariadb Mariadb.
How do I fix CVE-2022-27387?
Upgrade mariadb to a fixed version for your release line: 10.2.44, 10.3.35, 10.4.25 or 10.5.16.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2022-27387 being exploited?
There is no known exploitation of CVE-2022-27387 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2022-27387, AZL-9361, BIT-mariadb-2022-27387, BIT-mariadb-min-2022-27387, BIT-mysql-client-2022-27387, DEBIAN-CVE-2022-27387 and 2 more.