CVE-2022-27444 Null dereference in n/a

High 7.5 Published Updated

A segmentation fault in MariaDB Server allows attackers to cause a denial of service via crafted subselect queries.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-27444?

CVE-2022-27444 is a high-severity vulnerability in Mariadb Mariadb, published on 14 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

MariaDB Server v10.9 and below was discovered to contain a segmentation fault via the component sql/item_subselect.cc.

Which versions are affected by CVE-2022-27444?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.

PackageAffectedFixed in
mariadb BitnamiFrom 10.4.010.4.25, 10.5.16, 10.6.8, 10.7.4
mariadb-min BitnamiFrom 10.4.010.4.25, 10.5.16, 10.6.8, 10.7.4
mysql-client BitnamiFrom 10.4.010.4.25, 10.5.16, 10.6.8, 10.7.4

Products include Mariadb Mariadb.

How do I fix CVE-2022-27444?

Upgrade mariadb to a fixed version for your release line: 10.4.25, 10.5.16, 10.6.8 or 10.7.4.

Is CVE-2022-27444 being exploited?

There is no known exploitation of CVE-2022-27444 in the wild and no public exploit code.

All Mariadb Mariadb vulnerabilities

Sources

Also known as ALPINE-CVE-2022-27444, BIT-mariadb-2022-27444, BIT-mariadb-min-2022-27444, BIT-mysql-client-2022-27444, DEBIAN-CVE-2022-27444, GHSA-pc84-v5fr-8p3f and 1 more.

Is CVE-2022-27444 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free