CVE-2022-27446 Null dereference in n/a

High 7.5 Published Updated

A segmentation fault in MariaDB Server allows attackers to cause a denial of service via the item_cmpfunc.h component.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-27446?

CVE-2022-27446 is a high-severity vulnerability in Mariadb Mariadb, published on 14 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

MariaDB Server v10.9 and below was discovered to contain a segmentation fault via the component sql/item_cmpfunc.h.

Which versions are affected by CVE-2022-27446?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.

PackageAffectedFixed in
mariadb BitnamiFrom 10.4.010.4.25, 10.5.16, 10.6.8, 10.7.4
mariadb-min BitnamiFrom 10.4.010.4.25, 10.5.16, 10.6.8, 10.7.4
mysql-client BitnamiFrom 10.4.010.4.25, 10.5.16, 10.6.8, 10.7.4

Products include Mariadb Mariadb.

How do I fix CVE-2022-27446?

Upgrade mariadb to a fixed version for your release line: 10.4.25, 10.5.16, 10.6.8 or 10.7.4.

Is CVE-2022-27446 being exploited?

There is no known exploitation of CVE-2022-27446 in the wild and no public exploit code.

All Mariadb Mariadb vulnerabilities

Sources

Also known as ALPINE-CVE-2022-27446, BIT-mariadb-2022-27446, BIT-mariadb-min-2022-27446, BIT-mysql-client-2022-27446, DEBIAN-CVE-2022-27446, GHSA-vfrr-qwmc-g5r4 and 1 more.

Is CVE-2022-27446 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free