CVE-2022-27447 Use after free in n/a
A use-after-free vulnerability in MariaDB Server allows attackers to potentially execute arbitrary code or cause a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-27447?
CVE-2022-27447 is a high-severity use after free vulnerability in Debian Debian Linux, published on 14 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MariaDB Server v10.9 and below was discovered to contain a use-after-free via the component Binary_string::free_buffer() at /sql/sql_string.h.
Weakness: CWE-416
Which versions are affected by CVE-2022-27447?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.3.0 | 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mariadb-min Bitnami | From 10.3.0 | 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mysql-client Bitnami | From 10.3.0 | 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
Products include Debian Debian Linux, Mariadb Mariadb.
How do I fix CVE-2022-27447?
Upgrade mariadb to a fixed version for your release line: 10.3.35, 10.4.25, 10.5.16 or 10.6.8.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2022-27447 being exploited?
There is no known exploitation of CVE-2022-27447 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2022-27447, AZL-9411, BIT-mariadb-2022-27447, BIT-mariadb-min-2022-27447, BIT-mysql-client-2022-27447, CVE-2022-27458 and 3 more.