CVE-2022-27448 Denial of service in n/a
An assertion failure in MariaDB Server allows attackers to cause a denial of service via specific database operations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-27448?
CVE-2022-27448 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 14 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
There is an Assertion failure in MariaDB Server v10.9 and below via 'node->pcur->rel_pos == BTR_PCUR_ON' at /row/row0mysql.cc.
Weakness: CWE-617
Which versions are affected by CVE-2022-27448?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.3.0 | 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mariadb-min Bitnami | From 10.3.0 | 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mysql-client Bitnami | From 10.3.0 | 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
Products include Debian Debian Linux, Mariadb Mariadb.
How do I fix CVE-2022-27448?
Upgrade mariadb to a fixed version for your release line: 10.3.35, 10.4.25, 10.5.16 or 10.6.8.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-27448 being exploited?
There is no known exploitation of CVE-2022-27448 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2022-27448, AZL-9412, BIT-mariadb-2022-27448, BIT-mariadb-min-2022-27448, BIT-mysql-client-2022-27448, DEBIAN-CVE-2022-27448 and 2 more.