CVE-2022-27449 Null dereference in n/a
A segmentation fault in MariaDB Server allows attackers to cause a denial of service via a crafted request.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-27449?
CVE-2022-27449 is a high-severity vulnerability in Debian Debian Linux, published on 14 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MariaDB Server v10.9 and below was discovered to contain a segmentation fault via the component sql/item_func.cc:148.
Which versions are affected by CVE-2022-27449?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mariadb-min Bitnami | All versions | 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mysql-client Bitnami | All versions | 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
Products include Debian Debian Linux, Mariadb Mariadb.
How do I fix CVE-2022-27449?
Upgrade mariadb to a fixed version for your release line: 10.3.35, 10.4.25, 10.5.16 or 10.6.8.
Is CVE-2022-27449 being exploited?
There is no known exploitation of CVE-2022-27449 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2022-27449, AZL-9413, BIT-mariadb-2022-27449, BIT-mariadb-min-2022-27449, BIT-mysql-client-2022-27449, DEBIAN-CVE-2022-27449 and 2 more.