# CVE-2022-27451: Null dereference in n/a

> A segmentation fault in MariaDB Server allows attackers to cause a denial of service via the field conversion component.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2022-27451, AZL-9414, BIT-mariadb-2022-27451, BIT-mariadb-min-2022-27451, BIT-mysql-client-2022-27451, DEBIAN-CVE-2022-27451, GHSA-7php-c48c-5jgv, UBUNTU-CVE-2022-27451

## What is CVE-2022-27451?

CVE-2022-27451 is a high-severity vulnerability in Mariadb Mariadb, published on 14 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MariaDB Server v10.9 and below was discovered to contain a segmentation fault via the component sql/field_conv.cc.

## Which versions are affected by CVE-2022-27451?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 10.4.0 | 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
| `mariadb-min` | Bitnami | From 10.4.0 | 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
| `mysql-client` | Bitnami | From 10.4.0 | 10.4.25, 10.5.16, 10.6.8, 10.7.4 |

Products: Mariadb Mariadb.

## How do I fix CVE-2022-27451?

Upgrade mariadb to a fixed version for your release line: 10.4.25, 10.5.16, 10.6.8 or 10.7.4.

## Is CVE-2022-27451 being exploited?

There is no known exploitation of CVE-2022-27451 in the wild and no public exploit code.

## Other vulnerabilities in Mariadb Mariadb

- [CVE-2026-49261](https://insights.sbomify.com/CVE-2026-49261/): MariaDB server has unsafe parameter handling in `wsrep_notify_cmd` (critical 10.0)
- [CVE-2026-85746](https://insights.sbomify.com/CVE-2026-85746/): MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections (critical 9.9)
- [CVE-2026-85748](https://insights.sbomify.com/CVE-2026-85748/): MariaDB: Use-after-free with a large number of SYS_REFCURSOR's (critical 9.9)
- [CVE-2026-92262](https://insights.sbomify.com/CVE-2026-92262/): MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass. (critical 9.9)
- [CVE-2023-26785](https://insights.sbomify.com/CVE-2023-26785/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-27451 and fix it if it is affected.

What it is: CVE-2022-27451 is a high-severity vulnerability in Mariadb Mariadb, published on 14 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-27451 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 10.4.0; fixed in 10.4.25, 10.5.16, 10.6.8, 10.7.4
- mariadb-min (Bitnami): affected from 10.4.0; fixed in 10.4.25, 10.5.16, 10.6.8, 10.7.4
- mysql-client (Bitnami): affected from 10.4.0; fixed in 10.4.25, 10.5.16, 10.6.8, 10.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-27451/ (Markdown: https://insights.sbomify.com/CVE-2022-27451/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-27451
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-27451
- OSV: https://osv.dev/vulnerability/CVE-2022-27451

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-27451/
Summaries are generated and may contain mistakes; the official description above is the record.
