CVE-2022-27455 Use after free in n/a

High 7.5 Published Updated

A use-after-free vulnerability in MariaDB Server allows attackers to potentially execute arbitrary code or cause a denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-27455?

CVE-2022-27455 is a high-severity use after free vulnerability in Mariadb Mariadb, published on 14 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

MariaDB Server v10.6.3 and below was discovered to contain an use-after-free in the component my_wildcmp_8bit_impl at /strings/ctype-simple.c.

Weakness: CWE-416

Which versions are affected by CVE-2022-27455?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.

PackageAffectedFixed in
mariadb BitnamiFrom 10.4.010.4.25, 10.5.16, 10.6.8, 10.7.4
mariadb-min BitnamiFrom 10.4.010.4.25, 10.5.16, 10.6.8, 10.7.4
mysql-client BitnamiFrom 10.4.010.4.25, 10.5.16, 10.6.8, 10.7.4

Products include Mariadb Mariadb.

How do I fix CVE-2022-27455?

Upgrade mariadb to a fixed version for your release line: 10.4.25, 10.5.16, 10.6.8 or 10.7.4.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2022-27455 being exploited?

There is no known exploitation of CVE-2022-27455 in the wild and no public exploit code.

All Mariadb Mariadb vulnerabilities

Sources

Also known as ALPINE-CVE-2022-27455, BIT-mariadb-2022-27455, BIT-mariadb-min-2022-27455, BIT-mysql-client-2022-27455, DEBIAN-CVE-2022-27455, GHSA-5265-h4f9-w9cf and 1 more.

Is CVE-2022-27455 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free