# CVE-2022-27479: SQL injection vulnerability in chart data API

> Attackers can execute arbitrary SQL commands via chart data requests in Apache Superset, potentially accessing or modifying database contents.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-superset-2022-27479, GHSA-wh73-hpcg-v32j, PYSEC-2022-188

## What is CVE-2022-27479?

CVE-2022-27479 is a critical SQL injection vulnerability in Apache Superset, published on 13 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Superset before 1.4.2 is vulnerable to SQL injection in chart data requests. Users should update to 1.4.2 or higher which addresses this issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-27479?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 1.4.2 |
| `apache-superset` | PyPI | All versions | 1.4.2 |
| `apache-superset` | PyPI | All versions | 1.4.2 |
| `superset` | Bitnami | All versions | 1.4.2 |

Products: Apache Superset.

## How do I fix CVE-2022-27479?

Upgrade apache-superset to 1.4.2 or later.

## Is CVE-2022-27479 being exploited?

There is no known exploitation of CVE-2022-27479 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)
- [CVE-2021-41971](https://insights.sbomify.com/CVE-2021-41971/): Possible SQL Injection when template processing is enabled (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-27479 and fix it if it is affected.

What it is: CVE-2022-27479 is a critical SQL injection vulnerability in Apache Superset, published on 13 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-27479 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 1.4.2
- apache-superset (PyPI): affected all versions; fixed in 1.4.2
- apache-superset (PyPI): affected all versions; fixed in 1.4.2
- superset (Bitnami): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-27479/ (Markdown: https://insights.sbomify.com/CVE-2022-27479/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-27479
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-27479
- OSV: https://osv.dev/vulnerability/CVE-2022-27479

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-27479/
Summaries are generated and may contain mistakes; the official description above is the record.
