# CVE-2022-27649: Podman's default inheritable capabilities for linux container not empty

> Attackers with access to programs with inheritable file capabilities can elevate privileges within Podman containers due to incorrect default permission settings.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-9320, DEBIAN-CVE-2022-27649, GHSA-qvf8-p83w-v58j, GO-2022-0416, UBUNTU-CVE-2022-27649, openSUSE-SU-2024:11982-1

## What is CVE-2022-27649?

CVE-2022-27649 is a high-severity vulnerability in Fedoraproject Fedora, published on 4 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Podman, where containers were started incorrectly with non-empty default permissions. A vulnerability was found in Moby (Docker Engine), where containers were started incorrectly with non-empty inheritable Linux process capabilities. This flaw allows an attacker with access to programs with inheritable file capabilities to elevate those capabilities to the permitted set when execve(2) runs.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2022-27649?

6 open source packages ship an affected version, including github.com/containers/podman/v4, github.com/containers/podman and github.com/containers/podman/v2. It affects 14 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/podman/v4` | Go | All versions | 4.0.3 |
| `github.com/containers/podman/v4` | Go | All versions | 4.0.3 |
| `github.com/containers/podman/v4` | Go | All versions | 4.0.3 |
| `github.com/containers/podman` | Go | All versions | None |
| `github.com/containers/podman/v2` | Go | All versions | None |
| `github.com/containers/podman/v3` | Go | All versions | None |
| `podman` | openSUSE:Tumbleweed | All versions | 4.0.3-1.1 |

Products: Fedoraproject Fedora, Podman Project Podman, Redhat Developer Tools, Redhat Enterprise Linux, Redhat Enterprise Linux Eus, Redhat Enterprise Linux for Ibm Z Systems, Redhat Enterprise Linux for Ibm Z Systems Eus, Redhat Enterprise Linux for Power Little Endian, Redhat Enterprise Linux for Power Little Endian Eus, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Server for Power Little Endian Update Services for Sap Solutions, Redhat Enterprise Linux Server Tus, Redhat Enterprise Linux Server Update Services for Sap Solutions, Redhat Openshift Container Platform.

## How do I fix CVE-2022-27649?

Upgrade github.com/containers/podman/v4 to 4.0.3 or later.

## Is CVE-2022-27649 being exploited?

There is no known exploitation of CVE-2022-27649 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-27649 and fix it if it is affected.

What it is: CVE-2022-27649 is a high-severity vulnerability in Fedoraproject Fedora, published on 4 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-27649 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containers/podman/v4 (Go): affected all versions; fixed in 4.0.3
- github.com/containers/podman/v4 (Go): affected all versions; fixed in 4.0.3
- github.com/containers/podman/v4 (Go): affected all versions; fixed in 4.0.3
- github.com/containers/podman (Go): affected all versions; no fix listed
- github.com/containers/podman/v2 (Go): affected all versions; no fix listed
- github.com/containers/podman/v3 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-27649/ (Markdown: https://insights.sbomify.com/CVE-2022-27649/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-27649
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-27649
- OSV: https://osv.dev/vulnerability/CVE-2022-27649

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-27649/
Summaries are generated and may contain mistakes; the official description above is the record.
