# CVE-2022-27651: Non-empty default inheritable capabilities for linux container in Buildah

> Attackers with access to programs with inheritable file capabilities can elevate privileges within Buildah containers due to incorrect default permission settings.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-11513, AZL-36934, AZL-39870, AZL-9318, DEBIAN-CVE-2022-27651, GHSA-c3g4-w6cv-6v7h, GO-2022-0417, SUSE-SU-2022:1437-1, SUSE-SU-2022:2680-1, UBUNTU-CVE-2022-27651, openSUSE-SU-2024:11964-1

## What is CVE-2022-27651?

CVE-2022-27651 is a medium-severity vulnerability in Fedoraproject Fedora, published on 4 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in buildah where containers were incorrectly started with non-empty default permissions. A bug was found in Moby (Docker Engine) where containers were incorrectly started with non-empty inheritable Linux process capabilities, enabling an attacker with access to programs with inheritable file capabilities to elevate those capabilities to the permitted set when execve(2) runs. This has the potential to impact confidentiality and integrity.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2022-27651?

3 open source packages ship an affected version, including github.com/containers/buildah. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/buildah` | Go | All versions | 1.25.0 |
| `github.com/containers/buildah` | Go | All versions | 1.25.0 |
| `github.com/containers/buildah` | Go | All versions | 1.25.0 |
| `buildah` | SUSE:Linux Enterprise Module for Containers 15 SP3 | All versions | 1.25.1-150300.8.6.1 |
| `buildah` | SUSE:Linux Enterprise Module for Containers 15 SP4 | All versions | 1.25.1-150400.3.3.28 |
| `buildah` | openSUSE:Leap 15.3 | All versions | 1.25.1-150300.8.6.1 |
| `buildah` | openSUSE:Leap 15.4 | All versions | 1.25.1-150400.3.3.28 |
| `buildah` | openSUSE:Tumbleweed | All versions | 1.25.1-1.1 |

Products: Buildah Project Buildah, Fedoraproject Fedora, Redhat Enterprise Linux.

## How do I fix CVE-2022-27651?

Upgrade github.com/containers/buildah to 1.25.0 or later.

## Is CVE-2022-27651 being exploited?

There is no known exploitation of CVE-2022-27651 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2020-10696](https://insights.sbomify.com/CVE-2020-10696/): Path Traversal in Buildah (high 8.8)
- [CVE-2024-9675](https://insights.sbomify.com/CVE-2024-9675/): Buildah: buildah allows arbitrary directory mount (high 7.8)
- [CVE-2022-2990](https://insights.sbomify.com/CVE-2022-2990/): Buildah's incorrect handling of the supplementary groups may lead to data disclosure, modification (high 7.1)
- [CVE-2019-10214](https://insights.sbomify.com/CVE-2019-10214/): containers/image library Insufficiently Protects Credentials (medium 6.4)
- [CVE-2021-3602](https://insights.sbomify.com/CVE-2021-3602/): Buildah processes using chroot isolation may leak environment values to intermediate processes (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-27651 and fix it if it is affected.

What it is: CVE-2022-27651 is a medium-severity vulnerability in Fedoraproject Fedora, published on 4 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-27651 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containers/buildah (Go): affected all versions; fixed in 1.25.0
- github.com/containers/buildah (Go): affected all versions; fixed in 1.25.0
- github.com/containers/buildah (Go): affected all versions; fixed in 1.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-27651/ (Markdown: https://insights.sbomify.com/CVE-2022-27651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-27651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-27651
- OSV: https://osv.dev/vulnerability/CVE-2022-27651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-27651/
Summaries are generated and may contain mistakes; the official description above is the record.
