CVE-2022-27777 XSS Vulnerability in Action View tag helpers
Attackers can inject malicious scripts via controlled input in Action View tag helpers, potentially executing code in user browsers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-27777?
CVE-2022-27777 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 26 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A XSS Vulnerability in Action View tag helpers >= 5.2.0 and < 5.2.0 which would allow an attacker to inject content if able to control input into specific attributes.
Weakness: CWE-79
Which versions are affected by CVE-2022-27777?
8 open source packages ship an affected version, including actionview. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
actionview RubyGems | All versions | 5.2.7.1 |
actionview RubyGems | All versions | 5.2.7.1 |
actionview RubyGems | From 6.0.0 | 6.0.4.8 |
actionview RubyGems | From 6.0.0 | 6.0.4.8 |
actionview RubyGems | From 6.1.0 | 6.1.5.1 |
actionview RubyGems | From 6.1.0 | 6.1.5.1 |
2 more packages
actionview RubyGems | From 7.0.0 | 7.0.2.4 |
actionview RubyGems | From 7.0.0 | 7.0.2.4 |
Linux distribution packages (11)
rubygem-activesupport-5_1 SUSE:Linux Enterprise High Availability Extension 15 | All versions | 5.1.4-150000.3.9.1 |
rubygem-activesupport-5_1 SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 5.1.4-150000.3.9.1 |
rubygem-activesupport-5_1 SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 5.1.4-150000.3.9.1 |
rubygem-activesupport-5_1 SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 5.1.4-150000.3.9.1 |
rubygem-activesupport-5_1 SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 5.1.4-150000.3.9.1 |
rubygem-actionview-4_2 SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-9.15.1 |
rubygem-activesupport-4_2 SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-7.12.1 |
rubygem-actionview-4_2 SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-9.15.1 |
rubygem-activesupport-4_2 SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-7.12.1 |
rubygem-activesupport-5_1 openSUSE:Leap 15.3 | All versions | 5.1.4-150000.3.9.1 |
rubygem-activesupport-5_1 openSUSE:Leap 15.4 | All versions | 5.1.4-150000.3.9.1 |
Products include Debian Debian Linux, Rubyonrails Actionpack.
How do I fix CVE-2022-27777?
Upgrade actionview to a fixed version for your release line: 5.2.7.1, 6.0.4.8, 6.1.5.1 or 7.0.2.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-27777 being exploited?
There is no known exploitation of CVE-2022-27777 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2022-27777, GHSA-ch3h-j2vf-95pv, SUSE-SU-2022:3621-1, SUSE-SU-2022:3860-1, UBUNTU-CVE-2022-27777.