# CVE-2022-27777: XSS Vulnerability in Action View tag helpers

> Attackers can inject malicious scripts via controlled input in Action View tag helpers, potentially executing code in user browsers.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-27777, GHSA-ch3h-j2vf-95pv, SUSE-SU-2022:3621-1, SUSE-SU-2022:3860-1, UBUNTU-CVE-2022-27777

## What is CVE-2022-27777?

CVE-2022-27777 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 26 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A XSS Vulnerability in Action View tag helpers >= 5.2.0 and < 5.2.0 which would allow an attacker to inject content if able to control input into specific attributes.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-27777?

8 open source packages ship an affected version, including actionview. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionview` | RubyGems | All versions | 5.2.7.1 |
| `actionview` | RubyGems | All versions | 5.2.7.1 |
| `actionview` | RubyGems | From 6.0.0 | 6.0.4.8 |
| `actionview` | RubyGems | From 6.0.0 | 6.0.4.8 |
| `actionview` | RubyGems | From 6.1.0 | 6.1.5.1 |
| `actionview` | RubyGems | From 6.1.0 | 6.1.5.1 |
| `actionview` | RubyGems | From 7.0.0 | 7.0.2.4 |
| `actionview` | RubyGems | From 7.0.0 | 7.0.2.4 |
| `rubygem-activesupport-5_1` | SUSE:Linux Enterprise High Availability Extension 15 | All versions | 5.1.4-150000.3.9.1 |
| `rubygem-activesupport-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 5.1.4-150000.3.9.1 |
| `rubygem-activesupport-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 5.1.4-150000.3.9.1 |
| `rubygem-activesupport-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 5.1.4-150000.3.9.1 |
| `rubygem-activesupport-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 5.1.4-150000.3.9.1 |
| `rubygem-actionview-4_2` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-9.15.1 |
| `rubygem-activesupport-4_2` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-7.12.1 |
| `rubygem-actionview-4_2` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-9.15.1 |
| `rubygem-activesupport-4_2` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-7.12.1 |
| `rubygem-activesupport-5_1` | openSUSE:Leap 15.3 | All versions | 5.1.4-150000.3.9.1 |
| `rubygem-activesupport-5_1` | openSUSE:Leap 15.4 | All versions | 5.1.4-150000.3.9.1 |

Products: Debian Debian Linux, Rubyonrails Actionpack.

## How do I fix CVE-2022-27777?

Upgrade actionview to a fixed version for your release line: 5.2.7.1, 6.0.4.8, 6.1.5.1 or 7.0.2.4.

## Is CVE-2022-27777 being exploited?

There is no known exploitation of CVE-2022-27777 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-27777 and fix it if it is affected.

What it is: CVE-2022-27777 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 26 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-27777 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionview (RubyGems): affected all versions; fixed in 5.2.7.1
- actionview (RubyGems): affected all versions; fixed in 5.2.7.1
- actionview (RubyGems): affected from 6.0.0; fixed in 6.0.4.8
- actionview (RubyGems): affected from 6.0.0; fixed in 6.0.4.8
- actionview (RubyGems): affected from 6.1.0; fixed in 6.1.5.1
- actionview (RubyGems): affected from 6.1.0; fixed in 6.1.5.1
- actionview (RubyGems): affected from 7.0.0; fixed in 7.0.2.4
- actionview (RubyGems): affected from 7.0.0; fixed in 7.0.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-27777/ (Markdown: https://insights.sbomify.com/CVE-2022-27777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-27777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-27777
- OSV: https://osv.dev/vulnerability/CVE-2022-27777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-27777/
Summaries are generated and may contain mistakes; the official description above is the record.
