# CVE-2022-27815: Insecure Temporary File in SWHKD

> An attacker can exploit a predictable PID file path to leak information or cause a denial of service in the SWHKD keyboard daemon.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-p4jg-pccf-h82c

## What is CVE-2022-27815?

CVE-2022-27815 is a high-severity path traversal vulnerability in n/a, published on 29 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

SWHKD 1.1.5 unsafely uses the /tmp/swhkd.pid pathname. There can be an information leak or denial of service.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2022-27815?

2 open source packages ship an affected version, including Simple-Wayland-HotKey-Daemon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Simple-Wayland-HotKey-Daemon` | crates.io | All versions | 1.2.0 |
| `Simple-Wayland-HotKey-Daemon` | crates.io | All versions | 1.2.0 |

Products: Waycrate Swhkd.

## How do I fix CVE-2022-27815?

Upgrade Simple-Wayland-HotKey-Daemon to 1.2.0 or later.

## Is CVE-2022-27815 being exploited?

There is no known exploitation of CVE-2022-27815 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-27818](https://insights.sbomify.com/CVE-2022-27818/): Insecure temporary file usage in SWHKD (critical 9.1)
- [CVE-2022-27816](https://insights.sbomify.com/CVE-2022-27816/): Data Loss/Denial of Service in SWHKD (high 7.1)
- [CVE-2022-27819](https://insights.sbomify.com/CVE-2022-27819/): Unsafe parsing in SWHKD (medium 5.3)
- [CVE-2022-27817](https://insights.sbomify.com/CVE-2022-27817/): Exposure of Resource to Wrong Sphere in Simple-Wayland-HotKey-Daemon (medium 4.4)
- [CVE-2022-27814](https://insights.sbomify.com/CVE-2022-27814/): Exposure of Resource to Wrong Sphere in Simple-Wayland-HotKey-Daemon (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-27815 and fix it if it is affected.

What it is: CVE-2022-27815 is a high-severity path traversal vulnerability in n/a, published on 29 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-27815 in the wild and no public exploit code.

Affected packages and fixed versions:
- Simple-Wayland-HotKey-Daemon (crates.io): affected all versions; fixed in 1.2.0
- Simple-Wayland-HotKey-Daemon (crates.io): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-27815/ (Markdown: https://insights.sbomify.com/CVE-2022-27815/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-27815
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-27815
- OSV: https://osv.dev/vulnerability/CVE-2022-27815

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-27815/
Summaries are generated and may contain mistakes; the official description above is the record.
