{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-27889 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-27889 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-27889 is a medium-severity denial of service vulnerability in Palantir Foundry Multipass, published on 14 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-27889 and fix it if it is affected.\n\nWhat it is: CVE-2022-27889 is a medium-severity denial of service vulnerability in Palantir Foundry Multipass, published on 14 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-27889 in the wild and no public exploit code.\n\nAffected product: Palantir Foundry Multipass. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-27889/ (Markdown: https://insights.sbomify.com/CVE-2022-27889/index.md)","id":"CVE-2022-27889","markdown":"https://insights.sbomify.com/CVE-2022-27889/index.md","name":"CVE-2022-27889","record":{"aliases":["GHSA-q76q-x9c4-447v"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Palantir Foundry Multipass","requires_auth":"none","summary":"Attackers can cause denial of service for authentication and authorization operations in Palantir Foundry Multipass, leading to login failures.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Palantir","cpe":[{"product":"foundry_multipass","vendor":"palantir"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-913","name":"Improper Control of Dynamically-Managed Code Resources"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"The Multipass service was found to have code paths that could be abused to cause a denial of service for authentication or authorization operations. A malicious attacker could perform an application-level denial of service attack, potentially causing authentication and/or authorization operations to fail for the duration of the attack. This could lead to performance degradation or login failures for customer Palantir Foundry environments. This vulnerability is resolved in Multipass 3.647.0. This issue affects: Palantir Foundry Multipass versions prior to 3.647.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Denial of service in Foundry Multipass","id":"CVE-2022-27889","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":0,"n_references":1,"next":{"headline":"Weak cryptography in AtlasDB","id":"CVE-2022-27890"},"packages":[],"prev":{"headline":"The Foundry Issues service was found to be logging in a manner that captured session tokens.","id":"CVE-2022-27888"},"products":["Foundry Multipass"],"published":"2022-06-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Palantir"]},"summary":"Attackers can cause denial of service for authentication and authorization operations in Palantir Foundry Multipass, leading to login failures.","url":"https://insights.sbomify.com/CVE-2022-27889/"}