# CVE-2022-27889: Denial of service in Foundry Multipass

> Attackers can cause denial of service for authentication and authorization operations in Palantir Foundry Multipass, leading to login failures.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Jun 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-q76q-x9c4-447v

## What is CVE-2022-27889?

CVE-2022-27889 is a medium-severity denial of service vulnerability in Palantir Foundry Multipass, published on 14 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Multipass service was found to have code paths that could be abused to cause a denial of service for authentication or authorization operations. A malicious attacker could perform an application-level denial of service attack, potentially causing authentication and/or authorization operations to fail for the duration of the attack. This could lead to performance degradation or login failures for customer Palantir Foundry environments. This vulnerability is resolved in Multipass 3.647.0. This issue affects: Palantir Foundry Multipass versions prior to 3.647.0.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-27889?

It affects 1 product.


Products: Palantir Foundry Multipass.

## How do I fix CVE-2022-27889?

No fix has been published for CVE-2022-27889 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-27889 being exploited?

There is no known exploitation of CVE-2022-27889 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-27889 and fix it if it is affected.

What it is: CVE-2022-27889 is a medium-severity denial of service vulnerability in Palantir Foundry Multipass, published on 14 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-27889 in the wild and no public exploit code.

Affected product: Palantir Foundry Multipass. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-27889/ (Markdown: https://insights.sbomify.com/CVE-2022-27889/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-27889
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-27889
- OSV: https://osv.dev/vulnerability/CVE-2022-27889

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-27889/
Summaries are generated and may contain mistakes; the official description above is the record.
