# CVE-2022-27914: [20221101] - Core - RXSS through reflection of user input in com_media

> Reflected XSS in Joomla com_media allows attackers to execute scripts in victim browsers, potentially leading to session hijacking or account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Nov 2022
- **Updated:** 26 Nov 2024
- **Also known as:** BIT-joomla-2022-27914, GHSA-vwc4-4qvh-4xqq

## What is CVE-2022-27914?

CVE-2022-27914 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\!, published on 8 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Joomla! 4.0.0 through 4.2.4. Inadequate filtering of potentially malicious user input leads to reflected XSS vulnerabilities in com_media.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-27914?

1 open source package ship an affected version, including joomla. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla` | Bitnami | From 4.0.0 | 4.2.5 |

Products: Joomla Joomla\!.

## How do I fix CVE-2022-27914?

Upgrade joomla to 4.2.5 or later.

## Is CVE-2022-27914 being exploited?

There is no known exploitation of CVE-2022-27914 in the wild and no public exploit code.

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2016-10033](https://insights.sbomify.com/CVE-2016-10033/): PHPMailer Command Injection (critical 9.8, exploited in the wild)
- [CVE-2023-23752](https://insights.sbomify.com/CVE-2023-23752/): Joomla! Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-27914 and fix it if it is affected.

What it is: CVE-2022-27914 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\!, published on 8 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-27914 in the wild and no public exploit code.

Affected packages and fixed versions:
- joomla (Bitnami): affected from 4.0.0; fixed in 4.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-27914/ (Markdown: https://insights.sbomify.com/CVE-2022-27914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-27914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-27914
- OSV: https://osv.dev/vulnerability/CVE-2022-27914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-27914/
Summaries are generated and may contain mistakes; the official description above is the record.
