# CVE-2022-27949: Apache Airflow prior to 2.3.1 may include sensitive values in rendered template

> Attackers can view unmasked secrets in rendered templates for failed tasks, exposing sensitive data to unauthorized users.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2022
- **Updated:** 30 Apr 2025
- **Also known as:** BIT-airflow-2022-27949, GHSA-fvw2-2pf7-77vw, PYSEC-2022-42981

## What is CVE-2022-27949?

CVE-2022-27949 is a high-severity vulnerability in Apache Airflow, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in UI of Apache Airflow allows an attacker to view unmasked secrets in rendered template values for tasks which were not executed (for example when they were depending on past and previous instances of the task failed). This issue affects Apache Airflow prior to 2.3.1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-27949?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.3.1 |
| `apache-airflow` | PyPI | All versions | 2.3.1 |
| `apache-airflow` | PyPI | All versions | 2.3.1 |
| `airflow` | Bitnami | All versions | 2.3.1 |

Products: Apache Airflow.

## How do I fix CVE-2022-27949?

Upgrade apache-airflow to 2.3.1 or later.

## Is CVE-2022-27949 being exploited?

There is no known exploitation of CVE-2022-27949 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-27949 and fix it if it is affected.

What it is: CVE-2022-27949 is a high-severity vulnerability in Apache Airflow, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-27949 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.3.1
- apache-airflow (PyPI): affected all versions; fixed in 2.3.1
- apache-airflow (PyPI): affected all versions; fixed in 2.3.1
- airflow (Bitnami): affected all versions; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-27949/ (Markdown: https://insights.sbomify.com/CVE-2022-27949/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-27949
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-27949
- OSV: https://osv.dev/vulnerability/CVE-2022-27949

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-27949/
Summaries are generated and may contain mistakes; the official description above is the record.
