# CVE-2022-28056: Incorrect Permission Assignment for Critical Resource in ShopXO

> An attacker can trigger a system re-installation via the install controller, potentially resetting the application and gaining administrative control.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-jfph-3hpg-2f65

## What is CVE-2022-28056?

CVE-2022-28056 is a critical missing authorization vulnerability in n/a, published on 2 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ShopXO v2.2.5 and below was discovered to contain a system re-install vulnerability via the Add function in app/install/controller/Index.php.

## Which versions are affected by CVE-2022-28056?

2 open source packages ship an affected version, including shopxo/shopxo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopxo/shopxo` | Packagist | All versions | 2.2.6 |
| `shopxo/shopxo` | Packagist | All versions | 2.2.6 |

Products: Shopxo Shopxo.

## How do I fix CVE-2022-28056?

Upgrade shopxo/shopxo to 2.2.6 or later.

## Is CVE-2022-28056 being exploited?

There is no known exploitation of CVE-2022-28056 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-26325](https://insights.sbomify.com/CVE-2025-26325/): File upload in n/a (critical 9.8)
- [CVE-2020-19778](https://insights.sbomify.com/CVE-2020-19778/): Privilege escalation in n/a (critical 9.8)
- [CVE-2021-27817](https://insights.sbomify.com/CVE-2021-27817/): ShopXO RCE Vulnerability (critical 9.8)
- [CVE-2019-5886](https://insights.sbomify.com/CVE-2019-5886/): Missing authorization in n/a (critical 9.8)
- [CVE-2020-24220](https://insights.sbomify.com/CVE-2020-24220/): Command injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28056 and fix it if it is affected.

What it is: CVE-2022-28056 is a critical missing authorization vulnerability in n/a, published on 2 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28056 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopxo/shopxo (Packagist): affected all versions; fixed in 2.2.6
- shopxo/shopxo (Packagist): affected all versions; fixed in 2.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28056/ (Markdown: https://insights.sbomify.com/CVE-2022-28056/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28056
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28056
- OSV: https://osv.dev/vulnerability/CVE-2022-28056

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28056/
Summaries are generated and may contain mistakes; the official description above is the record.
