# CVE-2022-28133: Stored XSS vulnerability in Jenkins Bitbucket Server Integration Plugin

> Attackers with BitBucket consumer creation rights can inject malicious scripts via OAuth callback URLs, leading to stored XSS in Jenkins.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-45v7-65q8-x294

## What is CVE-2022-28133?

CVE-2022-28133 is a medium-severity cross-site scripting vulnerability in Jenkins Bitbucket Server Integration Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Bitbucket Server Integration Plugin 3.1.0 and earlier does not limit URL schemes for callback URLs on OAuth consumers, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to create BitBucket Server consumers.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-28133?

2 open source packages ship an affected version, including io.jenkins.plugins:atlassian-bitbucket-server-integration. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:atlassian-bitbucket-server-integration` | Maven | From 2.0.0 | 3.2.0 |
| `io.jenkins.plugins:atlassian-bitbucket-server-integration` | Maven | From 2.0.0 | 3.2.0 |

Products: Jenkins Bitbucket Server Integration.

## How do I fix CVE-2022-28133?

Upgrade io.jenkins.plugins:atlassian-bitbucket-server-integration to 3.2.0 or later.

## Is CVE-2022-28133 being exploited?

There is no known exploitation of CVE-2022-28133 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Bitbucket Server Integration Plugin

- [CVE-2025-24398](https://insights.sbomify.com/CVE-2025-24398/): Bitbucket Server Integration Plugin allows bypassing CSRF protection for any URL (high 8.8)
- [CVE-2022-28134](https://insights.sbomify.com/CVE-2022-28134/): Missing permission checks in Jekins Bitbucket Server Integration Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28133 and fix it if it is affected.

What it is: CVE-2022-28133 is a medium-severity cross-site scripting vulnerability in Jenkins Bitbucket Server Integration Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-28133 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:atlassian-bitbucket-server-integration (Maven): affected from 2.0.0; fixed in 3.2.0
- io.jenkins.plugins:atlassian-bitbucket-server-integration (Maven): affected from 2.0.0; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28133/ (Markdown: https://insights.sbomify.com/CVE-2022-28133/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28133
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28133
- OSV: https://osv.dev/vulnerability/CVE-2022-28133

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28133/
Summaries are generated and may contain mistakes; the official description above is the record.
