# CVE-2022-28135: Plaintext storage in Jenkins instant-messaging Plugin

> Attackers with file system access can read unencrypted group chat passwords stored in the Jenkins controller configuration.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hpm9-fx8v-w45v

## What is CVE-2022-28135?

CVE-2022-28135 is a medium-severity vulnerability in Jenkins instant-messaging Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins instant-messaging Plugin 1.41 and earlier stores passwords for group chats unencrypted in the global configuration file of plugins based on Jenkins instant-messaging Plugin on the Jenkins controller where they can be viewed by users with access to the Jenkins controller file system.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2022-28135?

2 open source packages ship an affected version, including org.jvnet.hudson.plugins:instant-messaging. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jvnet.hudson.plugins:instant-messaging` | Maven | All versions | 1.42 |
| `org.jvnet.hudson.plugins:instant-messaging` | Maven | All versions | 1.42 |

Products: Jenkins Instant-Messaging.

## How do I fix CVE-2022-28135?

Upgrade org.jvnet.hudson.plugins:instant-messaging to 1.42 or later.

## Is CVE-2022-28135 being exploited?

There is no known exploitation of CVE-2022-28135 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28135 and fix it if it is affected.

What it is: CVE-2022-28135 is a medium-severity vulnerability in Jenkins instant-messaging Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28135 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jvnet.hudson.plugins:instant-messaging (Maven): affected all versions; fixed in 1.42
- org.jvnet.hudson.plugins:instant-messaging (Maven): affected all versions; fixed in 1.42

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28135/ (Markdown: https://insights.sbomify.com/CVE-2022-28135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28135
- OSV: https://osv.dev/vulnerability/CVE-2022-28135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28135/
Summaries are generated and may contain mistakes; the official description above is the record.
