# CVE-2022-28138: CSRF vulnerability in Jenkins RocketChat Notifier Plugin

> Attackers can force users to connect to malicious URLs with stolen credentials via CSRF in the Jenkins RocketChat Notifier Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-x25h-f84x-wh4m

## What is CVE-2022-28138?

CVE-2022-28138 is a medium-severity vulnerability in Jenkins RocketChat Notifier Plugin, published on 29 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins RocketChat Notifier Plugin 1.4.10 and earlier allows attackers to connect to an attacker-specified URL using attacker-specified credential.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-28138?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:rocketchatnotifier. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:rocketchatnotifier` | Maven | All versions | 1.5.0 |
| `org.jenkins-ci.plugins:rocketchatnotifier` | Maven | All versions | 1.5.0 |

Products: Jenkins Rocketchat Notifier.

## How do I fix CVE-2022-28138?

Upgrade org.jenkins-ci.plugins:rocketchatnotifier to 1.5.0 or later.

## Is CVE-2022-28138 being exploited?

There is no known exploitation of CVE-2022-28138 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins RocketChat Notifier Plugin

- [CVE-2022-34802](https://insights.sbomify.com/CVE-2022-34802/): Plaintext Storage of a Password in Jenkins RocketChat Notifier Plugin (medium 4.3)
- [CVE-2022-28139](https://insights.sbomify.com/CVE-2022-28139/): Missing permission check in Jenkins RocketChat Notifier Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28138 and fix it if it is affected.

What it is: CVE-2022-28138 is a medium-severity vulnerability in Jenkins RocketChat Notifier Plugin, published on 29 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-28138 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:rocketchatnotifier (Maven): affected all versions; fixed in 1.5.0
- org.jenkins-ci.plugins:rocketchatnotifier (Maven): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28138/ (Markdown: https://insights.sbomify.com/CVE-2022-28138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28138
- OSV: https://osv.dev/vulnerability/CVE-2022-28138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28138/
Summaries are generated and may contain mistakes; the official description above is the record.
