{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:flaky-test-handler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-28140 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:flaky-test-handler to 1.2.2 or later.","what":"CVE-2022-28140 is a high-severity vulnerability in Jenkins Flaky Test Handler Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-28140 and fix it if it is affected.\n\nWhat it is: CVE-2022-28140 is a high-severity vulnerability in Jenkins Flaky Test Handler Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-28140 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:flaky-test-handler (Maven): affected all versions; fixed in 1.2.2\n- org.jenkins-ci.plugins:flaky-test-handler (Maven): affected all versions; fixed in 1.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-28140/ (Markdown: https://insights.sbomify.com/CVE-2022-28140/index.md)","id":"CVE-2022-28140","markdown":"https://insights.sbomify.com/CVE-2022-28140/index.md","name":"CVE-2022-28140","record":{"aliases":["GHSA-v4rr-65x6-g69f"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins Flaky Test Handler Plugin to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"flaky_test_handler","vendor":"jenkins"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Jenkins Flaky Test Handler Plugin 1.2.1 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE vulnerability in Jenkins Flaky Test Handler Plugin","id":"CVE-2022-28140","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Password stored in plain text by Jenkins Proxmox Plugin","id":"CVE-2022-28141"},"packages":[{"ecosystem":"Maven","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:flaky-test-handler","purl":null,"source":"GHSA-v4rr-65x6-g69f"},{"ecosystem":"Maven","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:flaky-test-handler","purl":"pkg:maven/org.jenkins-ci.plugins/flaky-test-handler","source":"GHSA-v4rr-65x6-g69f"}],"prev":{"headline":"Missing permission check in Jenkins RocketChat Notifier Plugin","id":"CVE-2022-28139"},"products":["Jenkins Flaky Test Handler Plugin"],"published":"2022-03-29","related":[{"cvss_score":5.4,"headline":"Jenkins Flaky Test Handler Plugin stored cross-site scripting vulnerability","id":"CVE-2023-40342","kev_date_added":null,"published":"2023-08-16"},{"cvss_score":4.3,"headline":"CSRF vulnerability in Jenkins Flaky Test Handler Plugin","id":"CVE-2020-2237","kev_date_added":null,"published":"2020-08-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins Flaky Test Handler Plugin to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2022-28140/"}