# CVE-2022-28142: SSL/TLS certificate validation globally disabled by Jenkins Proxmox Plugin

> The Jenkins Proxmox Plugin disables global SSL/TLS validation when configured to ignore issues, allowing man-in-the-middle attacks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-fhhx-r983-44xc

## What is CVE-2022-28142?

CVE-2022-28142 is a high-severity vulnerability in Jenkins Proxmox Plugin, published on 29 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Proxmox Plugin 0.6.0 and earlier disables SSL/TLS certificate validation globally for the Jenkins controller JVM when configured to ignore SSL/TLS issues.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2022-28142?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:proxmox. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:proxmox` | Maven | All versions | 0.7.0 |
| `org.jenkins-ci.plugins:proxmox` | Maven | All versions | 0.7.0 |

Products: Jenkins Proxmox.

## How do I fix CVE-2022-28142?

Upgrade org.jenkins-ci.plugins:proxmox to 0.7.0 or later.

## Is CVE-2022-28142 being exploited?

There is no known exploitation of CVE-2022-28142 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Proxmox Plugin

- [CVE-2022-28141](https://insights.sbomify.com/CVE-2022-28141/): Password stored in plain text by Jenkins Proxmox Plugin (medium 6.5)
- [CVE-2022-28143](https://insights.sbomify.com/CVE-2022-28143/): CSRF vulnerability in Proxmox Plugin (medium 6.5)
- [CVE-2022-28144](https://insights.sbomify.com/CVE-2022-28144/): Missing permission checks in Jenkins Proxmox Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28142 and fix it if it is affected.

What it is: CVE-2022-28142 is a high-severity vulnerability in Jenkins Proxmox Plugin, published on 29 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28142 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:proxmox (Maven): affected all versions; fixed in 0.7.0
- org.jenkins-ci.plugins:proxmox (Maven): affected all versions; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28142/ (Markdown: https://insights.sbomify.com/CVE-2022-28142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28142
- OSV: https://osv.dev/vulnerability/CVE-2022-28142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28142/
Summaries are generated and may contain mistakes; the official description above is the record.
