{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:proxmox. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-28143 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:proxmox to 0.7.1 or later.","what":"CVE-2022-28143 is a medium-severity vulnerability in Jenkins Proxmox Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-28143 and fix it if it is affected.\n\nWhat it is: CVE-2022-28143 is a medium-severity vulnerability in Jenkins Proxmox Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-28143 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:proxmox (Maven): affected all versions; fixed in 0.7.1\n- org.jenkins-ci.plugins:proxmox (Maven): affected all versions; fixed in 0.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-28143/ (Markdown: https://insights.sbomify.com/CVE-2022-28143/index.md)","id":"CVE-2022-28143","markdown":"https://insights.sbomify.com/CVE-2022-28143/index.md","name":"CVE-2022-28143","record":{"aliases":["GHSA-wjvr-2hjg-6rhj"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Proxmox Plugin","requires_auth":"low_privilege","summary":"Attackers can force Jenkins to connect to malicious hosts, disable SSL validation, and test rollbacks via CSRF in the Proxmox Plugin.","user_interaction":"not_required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"proxmox","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Proxmox Plugin 0.7.0 and earlier allows attackers to connect to an attacker-specified host using attacker-specified username and password (perform a connection test), disable SSL/TLS validation for the entire Jenkins controller JVM as part of the connection test (see CVE-2022-28142), and test a rollback with attacker-specified parameters.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF vulnerability in Proxmox Plugin","id":"CVE-2022-28143","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Missing permission checks in Jenkins Proxmox Plugin","id":"CVE-2022-28144"},"packages":[{"ecosystem":"Maven","fixed":["0.7.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:proxmox","purl":null,"source":"GHSA-wjvr-2hjg-6rhj"},{"ecosystem":"Maven","fixed":["0.7.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:proxmox","purl":"pkg:maven/org.jenkins-ci.plugins/proxmox","source":"GHSA-wjvr-2hjg-6rhj"}],"prev":{"headline":"SSL/TLS certificate validation globally disabled by Jenkins Proxmox Plugin","id":"CVE-2022-28142"},"products":["Jenkins Proxmox Plugin"],"published":"2022-03-29","related":[{"cvss_score":7.5,"headline":"SSL/TLS certificate validation globally disabled by Jenkins Proxmox Plugin","id":"CVE-2022-28142","kev_date_added":null,"published":"2022-03-29"},{"cvss_score":6.5,"headline":"Password stored in plain text by Jenkins Proxmox Plugin","id":"CVE-2022-28141","kev_date_added":null,"published":"2022-03-29"},{"cvss_score":6.5,"headline":"Missing permission checks in Jenkins Proxmox Plugin","id":"CVE-2022-28144","kev_date_added":null,"published":"2022-03-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers can force Jenkins to connect to malicious hosts, disable SSL validation, and test rollbacks via CSRF in the Proxmox Plugin.","url":"https://insights.sbomify.com/CVE-2022-28143/"}