# CVE-2022-28144: Missing permission checks in Jenkins Proxmox Plugin

> Attackers with read permissions can bypass authorization to perform connection tests and disable SSL validation on the Jenkins controller.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2mgj-mwvf-mpg5

## What is CVE-2022-28144?

CVE-2022-28144 is a medium-severity missing authorization vulnerability in Jenkins Proxmox Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Proxmox Plugin 0.7.0 and earlier does not perform a permission check in several HTTP endpoints, allowing attackers with Overall/Read permission to connect to an attacker-specified host using attacker-specified username and password (perform a connection test), disable SSL/TLS validation for the entire Jenkins controller JVM as part of the connection test (see CVE-2022-28142), and test a rollback with attacker-specified parameters.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-28144?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:proxmox. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:proxmox` | Maven | All versions | 0.7.1 |
| `org.jenkins-ci.plugins:proxmox` | Maven | All versions | 0.7.1 |

Products: Jenkins Proxmox.

## How do I fix CVE-2022-28144?

Upgrade org.jenkins-ci.plugins:proxmox to 0.7.1 or later.

## Is CVE-2022-28144 being exploited?

There is no known exploitation of CVE-2022-28144 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Proxmox Plugin

- [CVE-2022-28142](https://insights.sbomify.com/CVE-2022-28142/): SSL/TLS certificate validation globally disabled by Jenkins Proxmox Plugin (high 7.5)
- [CVE-2022-28141](https://insights.sbomify.com/CVE-2022-28141/): Password stored in plain text by Jenkins Proxmox Plugin (medium 6.5)
- [CVE-2022-28143](https://insights.sbomify.com/CVE-2022-28143/): CSRF vulnerability in Proxmox Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28144 and fix it if it is affected.

What it is: CVE-2022-28144 is a medium-severity missing authorization vulnerability in Jenkins Proxmox Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28144 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:proxmox (Maven): affected all versions; fixed in 0.7.1
- org.jenkins-ci.plugins:proxmox (Maven): affected all versions; fixed in 0.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28144/ (Markdown: https://insights.sbomify.com/CVE-2022-28144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28144
- OSV: https://osv.dev/vulnerability/CVE-2022-28144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28144/
Summaries are generated and may contain mistakes; the official description above is the record.
