{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:ci-with-toad-edge. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-28145 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:ci-with-toad-edge to 2.4 or later.","what":"CVE-2022-28145 is a medium-severity cross-site scripting vulnerability in Jenkins Continuous Integration with Toad Edge Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-28145 and fix it if it is affected.\n\nWhat it is: CVE-2022-28145 is a medium-severity cross-site scripting vulnerability in Jenkins Continuous Integration with Toad Edge Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-28145 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:ci-with-toad-edge (Maven): affected all versions; fixed in 2.4\n- org.jenkins-ci.plugins:ci-with-toad-edge (Maven): affected all versions; fixed in 2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-28145/ (Markdown: https://insights.sbomify.com/CVE-2022-28145/index.md)","id":"CVE-2022-28145","markdown":"https://insights.sbomify.com/CVE-2022-28145/index.md","name":"CVE-2022-28145","record":{"aliases":["GHSA-7jh8-ghwc-82cw"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Toad Edge Plugin","requires_auth":"low_privilege","summary":"Attackers with configure permissions can inject scripts into report files, leading to stored XSS in Jenkins Toad Edge Plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"continuous_integration_with_toad_edge","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Continuous Integration with Toad Edge Plugin 2.3 and earlier does not apply Content-Security-Policy headers to report files it serves, resulting in a stored cross-site scripting (XSS) exploitable by attackers with Item/Configure permission or otherwise able to control report contents.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS) vulnerability in Jenkins Continuous Integration with Toad Edge Plugin","id":"CVE-2022-28145","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Arbitrary file read vulnerability in Jenkins Continuous Integration with Toad Edge Plugin","id":"CVE-2022-28146"},"packages":[{"ecosystem":"Maven","fixed":["2.4"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:ci-with-toad-edge","purl":null,"source":"GHSA-7jh8-ghwc-82cw"},{"ecosystem":"Maven","fixed":["2.4"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:ci-with-toad-edge","purl":"pkg:maven/org.jenkins-ci.plugins/ci-with-toad-edge","source":"GHSA-7jh8-ghwc-82cw"}],"prev":{"headline":"Missing permission checks in Jenkins Proxmox Plugin","id":"CVE-2022-28144"},"products":["Jenkins Continuous Integration with Toad Edge Plugin"],"published":"2022-03-29","related":[{"cvss_score":6.5,"headline":"Arbitrary file read vulnerability in Jenkins Continuous Integration with Toad Edge Plugin","id":"CVE-2022-28146","kev_date_added":null,"published":"2022-03-29"},{"cvss_score":6.5,"headline":"Path traversal vulnerability on Windows in Jenkins Continuous Integration with Toad Edge Plugin","id":"CVE-2022-28148","kev_date_added":null,"published":"2022-03-29"},{"cvss_score":4.3,"headline":"Missing permission check in Jenkins Continuous Integration with Toad Edge Plugin","id":"CVE-2022-28147","kev_date_added":null,"published":"2022-03-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers with configure permissions can inject scripts into report files, leading to stored XSS in Jenkins Toad Edge Plugin.","url":"https://insights.sbomify.com/CVE-2022-28145/"}