# CVE-2022-28147: Missing permission check in Jenkins Continuous Integration with Toad Edge Plugin

> Attackers with read permissions can verify the existence of arbitrary files on the Jenkins controller file system due to missing permission checks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8hh2-rxm8-7fj8

## What is CVE-2022-28147?

CVE-2022-28147 is a medium-severity missing authorization vulnerability in Jenkins Continuous Integration with Toad Edge Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins Continuous Integration with Toad Edge Plugin 2.3 and earlier allows attackers with Overall/Read permission to check for the existence of an attacker-specified file path on the Jenkins controller file system.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-28147?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:ci-with-toad-edge. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:ci-with-toad-edge` | Maven | All versions | 2.4 |
| `org.jenkins-ci.plugins:ci-with-toad-edge` | Maven | All versions | 2.4 |

Products: Jenkins Continuous Integration With Toad Edge.

## How do I fix CVE-2022-28147?

Upgrade org.jenkins-ci.plugins:ci-with-toad-edge to 2.4 or later.

## Is CVE-2022-28147 being exploited?

There is no known exploitation of CVE-2022-28147 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Continuous Integration with Toad Edge Plugin

- [CVE-2022-28146](https://insights.sbomify.com/CVE-2022-28146/): Arbitrary file read vulnerability in Jenkins Continuous Integration with Toad Edge Plugin (medium 6.5)
- [CVE-2022-28148](https://insights.sbomify.com/CVE-2022-28148/): Path traversal vulnerability on Windows in Jenkins Continuous Integration with Toad Edge Plugin (medium 6.5)
- [CVE-2022-28145](https://insights.sbomify.com/CVE-2022-28145/): Cross-site Scripting (XSS) vulnerability in Jenkins Continuous Integration with Toad Edge Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28147 and fix it if it is affected.

What it is: CVE-2022-28147 is a medium-severity missing authorization vulnerability in Jenkins Continuous Integration with Toad Edge Plugin, published on 29 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28147 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:ci-with-toad-edge (Maven): affected all versions; fixed in 2.4
- org.jenkins-ci.plugins:ci-with-toad-edge (Maven): affected all versions; fixed in 2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28147/ (Markdown: https://insights.sbomify.com/CVE-2022-28147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28147
- OSV: https://osv.dev/vulnerability/CVE-2022-28147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28147/
Summaries are generated and may contain mistakes; the official description above is the record.
